Home Webboard ArticlesKnowledges  
ข่าวประกาศ:

:: กติกา มารยาท ในการใช้งานเว็บบอร์ด ::
กรุณากรอกอีเมล์จริงในการสมัคร และรับอีเมล์ยืนยันเพื่อใช้งานในบอร์ด

ผู้เขียน หัวข้อ: กระทู้ล่าสุดพร้อมรูปแบบนี้ ทำยากมั้ยครับ !!!!  (อ่าน 14977 ครั้ง)

0 สมาชิก และ 1 บุคคลทั่วไป กำลังดูหัวข้อนี้

ออฟไลน์ MrK

  • Just M
  • ***
  • กระทู้: 51
  • เห็นด้วย&ขอบคุณ: 7
สวัสดีครับชาวจัสทุกท่าน ผมไม่ได้เข้ามาค่อนข้างนาน พอสมควร ก่อนอื่นต้องขอขอบคุณ justuser อีกครั้ง ผมได้ความรู้จากที่นี่ เกี่ยวกับ smf ไปเยอะมาก ทุกวันนี้ ผมทำเว็บบอร์ดของตัวเอง และสามารถอัพ mod ได้เยอะพอสมควร ทั้งๆที่ผมไม่เคยเรียนการเขียนโค๊ดใดๆทั้งสิ้น ให้เขียน html ธรรมดาๆ ตอนนี้ยังเขียนไม่ได้เลย อาศัยจำ copy แล้ว past ตลอด เปิดดูจาก dream จาก google เอาตลอด ลองผิดลองถูกมาก็เยอะ
เข้าเรื่องเลยดีกว่า  ตอนนี้ผมใช้บอร์ด smf 2.0.3 อยู่ ลง simpleportal เรียบร้อย  ทุกอย่างเป็นที่น่าพอใจ ผมแฮปปี้กับ simpleportal มาก ทำอะไรได้เยอะดี  แต่ทั้งนี้แหละทั้งนั้น ขึ้นชื่อว่าคน ความพอใจมันไม่เคยมีจุดสิ้นสุด  ผมเกิดไปเห็น กระทู้ล่าสุด หรือ กระทู้น่าสนใจ แบบมีรูปประกอบ และก็มีไตเติ้ลของเวปนึง ชอบมาก ปิ้งตั้งแต่แรกเจอ ซึ่งผมก็มั่นใจว่าเว็ปนั้นเค้าใช้ simpleportal เหมือนกัน
 

ผมเลยลองค้นหา เซ็ทอัพดู เหมือนมันจะใช่ แต่ก็ไม่ใช่ บางอันดึงมาโชว์ ก็ได้แต่รูป ไม่มีหัวข้อ รูปก็มาแบบว่า หลายขนาดเหลือเกิน
ผมอยากจะถามท่านผู้รู้ว่า
-มันเป็นฟังชั่น ที่มีอยู่แล้ว หรือต้องมาโมโค๊ดเอาครับ  :embarrassed:
-ผมลองทำที่เว็ปผมแบบทำมือเองเลย แปะรูป ฝังลิ้งเอง ก็ดูได้ แต่คิดว่า คงไม่ใช่วิธี  :undecided:
-มีกระทู้ไหนแนะนำไว้มั้ยครับ เผื่อผมจะต่อยอดได้ เวปผมอยู่ที่  http://www.nissanpulsar-club.com

ไม่ว่าจะมีคนตอบหรือไม่ ผมขอขอบคุณไว้นะที่นี้ด้วยครับ




ออฟไลน์ Zone-My

  • Just Mem
  • ****
  • กระทู้: 60
  • เห็นด้วย&ขอบคุณ: 17
  • เพศ: ชาย
โซนมาย เเหล่งอาณาเขตออนไลน์ของคนไทย
------------------------------------------
zone-my.com :smitten:

ออฟไลน์ Zone-My

  • Just Mem
  • ****
  • กระทู้: 60
  • เห็นด้วย&ขอบคุณ: 17
  • เพศ: ชาย
อาจต้องรอให่พี่เซียว มาตอบครับ  :smiley:
โซนมาย เเหล่งอาณาเขตออนไลน์ของคนไทย
------------------------------------------
zone-my.com :smitten:

ออฟไลน์ Zone-My

  • Just Mem
  • ****
  • กระทู้: 60
  • เห็นด้วย&ขอบคุณ: 17
  • เพศ: ชาย
Recent Post with thumbnail ใช่ไหม ผมว่ามันต้องเเกะโค้ดเองอ่ะครับ ตัวอย่างทำกับบล็อกรูปด้านล่าง
โซนมาย เเหล่งอาณาเขตออนไลน์ของคนไทย
------------------------------------------
zone-my.com :smitten:

ออฟไลน์ เซียวเหล่งนึ่งฯ

  • Global Moderator
  • *
  • กระทู้: 5547
  • เห็นด้วย&ขอบคุณ: 2148
    • SMFjusthost.com
มีคนโมโค๊ดไว้ให้ละ
http://www.zone-it.com/b251/228531

ออฟไลน์ MrK

  • Just M
  • ***
  • กระทู้: 51
  • เห็นด้วย&ขอบคุณ: 7
ขอบคุณมากครับ เข้ามากี่ที ได้ประโยชน์มากมาก  :yaahoo:

ออฟไลน์ MrK

  • Just M
  • ***
  • กระทู้: 51
  • เห็นด้วย&ขอบคุณ: 7
เข้ามาส่งข่าวว่าผมคลำไปคลำมาจนทำได้แล้ว  :haha:  แต่มันติดอยู่นิดนึง ตอนนำไปใช้งาน ผมนำไปใส่ใน block  custom html ของ simpleportal โดยการ IFRAME  เวลาโชว์ก็ปกติครับ  แต่เวลาคลิ๊กนี่สิ มันขึ้นหน้าใหม่อยู่ใน block นั่นแหละ ไม่ขึ้นหน้าใหม่ตามต้องการ อันนี้พอมีทางแก้มั้ยครับ
ขอบคุณครับ  :adore:

ออฟไลน์ ไก่ขี้เมา®

  • ไม่เต็มบาท™
  • Global Moderator
  • *
  • กระทู้: 1080
  • เห็นด้วย&ขอบคุณ: 1015
  • เพศ: ชาย

:boxing: :boxing: :boxing:

ออฟไลน์ MrK

  • Just M
  • ***
  • กระทู้: 51
  • เห็นด้วย&ขอบคุณ: 7
<iframe target=....>


http://www.w3schools.com/tags/att_link_target.asp
http://webdesign.about.com/od/iframes/qt/target-links-iframes-and-frames.htm



ขอบคุณครับ เดี๋ยวจะลองไปโมดูครับ  :adore:

ลืมไปว่า ผมลองเซ็ต target แล้ว มันก็แสดงผลอยู่ในบล๊อคนั้นแหละ ไม่ยอมขึ้นมาทับหน้าบอร์ดทั้งหมด แต่ถ้าเป็น html โค๊ดทั่วไป นำไปใส่ในบล๊อคของ simpleportal แล้วนำไปวาง มันจะเซ็ต target ได้ จะแสดงหน้าใหม่เลย ผมคิดว่าที่เป็นอยู่นี้ มันก็คงขึ้นหน้าใหม่แหละ แต่ใหม่อยู่ในบล๊อคอย่างเดิม  :undecided: ไม่ทราบมีวิธีแนะนำมั้ยครับ  ตามนี้ครับ ด้านล่างสุด  http://www.nissanpulsar-club.com/pulsar/index.php  บล๊อคด้านบน จะเป็นแบบ html ธรรมดามาใส่ในบล๊อค ทำงานปกติดี
ขอบคุณที่สละเวลามาช่วยเหลือครับ
รัฐนันท์
« แก้ไขครั้งสุดท้าย: 22, มกราคม 2013, 04:29:28 PM โดย MrK »

ออฟไลน์ เซียวเหล่งนึ่งฯ

  • Global Moderator
  • *
  • กระทู้: 5547
  • เห็นด้วย&ขอบคุณ: 2148
    • SMFjusthost.com
เขียนแบบนี้

<iframe name="picid2" width="100%" align="center" border="0" frameborder="0" src="http://gpsteawthai.com/picid2.php" height="420" target="_blank" scrolling="no">
</iframe>


ตัวอย่าง  gpsteawthai.com
ดูบล็อคด้านล่างๆ

ออฟไลน์ MrK

  • Just M
  • ***
  • กระทู้: 51
  • เห็นด้วย&ขอบคุณ: 7
เขียนแบบนี้

<iframe name="picid2" width="100%" align="center" border="0" frameborder="0" src="http://gpsteawthai.com/picid2.php" height="420" target="_blank" scrolling="no">
</iframe>


ตัวอย่าง  gpsteawthai.com
ดูบล็อคด้านล่างๆ


ผมลองเอาไปใส่ทั้งดุ้นเลย ปรากฎว่า ใช้การได้ครับ ลิ้งค์ขึ้นหน้าใหม่อย่างไม่มีปัญหา  เพราะฉนั้น ปัญหาน่าจะมาจากไฟล์  xpic.php ที่ผมทำขึ้น ฟรือใน SSI.php ที่โมขึ้นมา พอบอกได้มั้ยครัล ว่าน่าจะมาจากไฟล์ไหน  :sad:

ออฟไลน์ เซียวเหล่งนึ่งฯ

  • Global Moderator
  • *
  • กระทู้: 5547
  • เห็นด้วย&ขอบคุณ: 2148
    • SMFjusthost.com
ขอดูหน้าเว็บของท่าน ที่เอาเฟรม xpic.php  ไปแสดง

ออฟไลน์ MrK

  • Just M
  • ***
  • กระทู้: 51
  • เห็นด้วย&ขอบคุณ: 7
หน้าแรกเลยครับ ผมแทรกโดยใช้บล๊อคของ simpleportal เป็นบล๊อค html วางไว้บล๊อคล่างสุดเลย ลองแทรก iframe ที่คุณเซียวเหล่งนึงให้ตัวอย่างมาด้วย วางไว้คู่กัน  :evil:  ลองคลิกแล้วแสดงต่างที่กันเลย  :hitwall:
ไฟล์ xpic อยู่ที่นี่  http://www.nissanpulsar-club.com/pulsar/xpic.php 


<?
require_once('SSI.php');

$ratio = 3/4;
$width = 190;
$height = $width * $ratio;

echo '
<style type="text/css">
#zone-pic a{
color:#990066;
text-decoration:none;
text-align:center;
font-size:14px;
line-height:14px;
display:block;
}
#zone-pic a:hover {
text-decoration: none;
color: #FF0000;
}
#zone-pic .item{
width:190px;
float:left;
margin:8px;
}
#zone-pic .item .thumb{ /** css crop image **/
width: 200px;
height:150px;
padding:5px;
overflow:hidden;
background:#fff;
border:3px #ccc;

}
#zone-pic .item img{ /** css trick full width aspect ratio **/

width:100%;
height:auto;
min-height:100%;
display:block;
}
#zone-pic .row{
display:block;
clear:both;
}
</style>';

$num = 10;
$links = array();
foreach(ssi_zpic(5,'ID_TOPIC',14) as $topic)
{
$links[] = '
<div class="item">
<a class="thumb" href="'.$scripturl.'?topic='.$topic['id'].'" title="คลิ๊กดูรูปใหญ่"><img src="'.$topic['pic'].'" alt="" /></a>
<a href="'.$scripturl.'?topic='.$topic['id'].'" title="">'.$topic['subject'].'</a>
</div>';
}

$nRow = 2;

echo '<div id="zone-pic">';
for($i=0;$i<$nRow;$i++)
{
$row = array_splice($links,0,floor($num/$nRow));
echo '
<div class="row">'.implode(' ',$row).'</div>';
}
echo '</div>';

ลบกวนด้วยครับ  :adore:

ออฟไลน์ เซียวเหล่งนึ่งฯ

  • Global Moderator
  • *
  • กระทู้: 5547
  • เห็นด้วย&ขอบคุณ: 2148
    • SMFjusthost.com
ลองจับ target ใส่เข้าไปยังงี้ดู

<a class="thumb" href="'.$scripturl.'?topic='.$topic['id']. '" title="คลิ๊กดูรูปใหญ่"><img src="'.$topic['pic'].'" alt="" target='_blank' /></a>
<a href="'.$scripturl.'?topic='.$topic['id'].'" title="" target='_blank'>'.$topic['subject'].'</a>

ออฟไลน์ MrK

  • Just M
  • ***
  • กระทู้: 51
  • เห็นด้วย&ขอบคุณ: 7
ลองจับ target ใส่เข้าไปยังงี้ดู

<a class="thumb" href="'.$scripturl.'?topic='.$topic['id']. '" title="คลิ๊กดูรูปใหญ่"><img src="'.$topic['pic'].'" alt="" target='_blank' /></a>
<a href="'.$scripturl.'?topic='.$topic['id'].'" title="" target='_blank'>'.$topic['subject'].'</a>

ได้แล้วครับ ขอบคุณมากๆครับ  :adore: :adore: :adore:  แต่คุณเซียวเหล่งนึ่ง วาง target สลับที่กันมาให้นะครับ ทีแรกใส่ มัน eror เลย อิอิ  แก้ไขเรียบร้อยครับ ขอบคุณมากครับ just คือเวปของผู้ให้จริงๆ  :yaahoo:

 

Sitemap 1 2 3 4 5 6 
Back to top