Home Webboard ArticlesKnowledges  

ผู้เขียน หัวข้อ: upgrade smf 1.1 RC2 เป็น 1.1.5 แล้วเกิดข้อผิดพลาดค่ะ  (อ่าน 15823 ครั้ง)

0 สมาชิก และ 1 บุคคลทั่วไป กำลังดูหัวข้อนี้

ออฟไลน์ GB_LOVE

  • Ju
  • *
  • กระทู้: 18
  • เห็นด้วย&ขอบคุณ: 2
Re: upgrade smf 1.1 RC2 เป็น 1.1.5 แล้วเกิดข้อผิดพลาดค่ะ
« ตอบกลับ #15 เมื่อ: 27, สิงหาคม 2008, 02:21:51 AM »
อ้อ จะบอกว่าหน้าบอร์ดดูได้แล้ว ข้อความส่วนตัว ข้อมูลสมาชิกต่างๆ ก็ดูได้ค่ะ แต่ที่มีปัญหาก็คือเวลาเข้าไปดูกระทู้จะมีปัญหาว่าโหลดไม่ได้ มันจะขึ้น Fatal error: Call to undefined function: calrpg() in /home/arnas/domains/arnasfanclub.com/public_html/forum/Sources/Load.php(1726) : eval()'d code on line 340 น่ะค่ะ

ยังไงก็ขอบคุณมากๆ นะคะที่ช่วยมาตอบปัญหาน่ะค่ะ

noname

  • บุคคลทั่วไป
Re: upgrade smf 1.1 RC2 เป็น 1.1.5 แล้วเกิดข้อผิดพลาดค่ะ
« ตอบกลับ #16 เมื่อ: 27, สิงหาคม 2008, 02:29:50 AM »
ติดต่อ hosting ให้อัฟเดท MySQL client เป็น version: 5.0.xx

ตอนนี้ติด config PHP ของ hosting แล้วไม่สามารถแก้ได้ด้วย user แต่ต้องแก้ในระดับ advanced user

ออฟไลน์ GB_LOVE

  • Ju
  • *
  • กระทู้: 18
  • เห็นด้วย&ขอบคุณ: 2
Re: upgrade smf 1.1 RC2 เป็น 1.1.5 แล้วเกิดข้อผิดพลาดค่ะ
« ตอบกลับ #17 เมื่อ: 27, สิงหาคม 2008, 02:36:38 AM »
ติดต่อ hosting ให้อัฟเดท MySQL client เป็น version: 5.0.xx

ตอนนี้ติด config PHP ของ hosting แล้วไม่สามารถแก้ได้ด้วย user แต่ต้องแก้ในระดับ advanced user





ตามรูปน่ะค่ะ mysql ของที่โฮสต์ก็เวอร์ชั่น  5.0.41 แล้วนะคะ ไม่น่าจะมีปัญหา เอ หรือจะเกี่ยวที่ phpmyadmin หรือเปล่าคะ อันนี้ไม่แน่ใจเลยค่ะ

ยังไงก็ทิ้งคำตอบไว้ได้นะคะ ตอนนี้ง่วงนอนแล้วค่ะ ยังไงถ้าใครที่ช่วยตอบปัญหาตรงนี้ได้ก็รบกวนช่วยแนะนำด้วยนะคะ ขอบคุณล่วงหน้าค่ะ :smitten-1:

noname

  • บุคคลทั่วไป
Re: upgrade smf 1.1 RC2 เป็น 1.1.5 แล้วเกิดข้อผิดพลาดค่ะ
« ตอบกลับ #18 เมื่อ: 27, สิงหาคม 2008, 02:43:23 AM »
ลองใช้วิธีเอาไฟล์ SMF 1.1.5 มา install บนฐานข้อมูลเดิมดูนะ

ถ้ามัน error DB จะแก้ง่ายกว่า error function เพราะถ้าหาก error function มันมีองค์ประกอบหลายอย่าง

รวมทั้ง hosting ก็เป็นปัจจัยหนึ่งเหมือนกัน

ออฟไลน์ GB_LOVE

  • Ju
  • *
  • กระทู้: 18
  • เห็นด้วย&ขอบคุณ: 2
Re: upgrade smf 1.1 RC2 เป็น 1.1.5 แล้วเกิดข้อผิดพลาดค่ะ
« ตอบกลับ #19 เมื่อ: 27, สิงหาคม 2008, 02:46:34 AM »
ลองใช้วิธีเอาไฟล์ SMF 1.1.5 มา install บนฐานข้อมูลเดิมดูนะ

ถ้ามัน error DB จะแก้ง่ายกว่า error function เพราะถ้าหาก error function มันมีองค์ประกอบหลายอย่าง

รวมทั้ง hosting ก็เป็นปัจจัยหนึ่งเหมือนกัน

ขอบคุณนะคะ ยังไงจะลองให้ทางโฮสต์ช่วยดูให้อีกที ขอบคุณทุกๆ คนมากๆ ค่ะ ถ้าไม่ได้คำแนะนำก็คงแก้ปัยหาไม่ได้ลุล่วงมาขนาดนี้ คิดว่าที่เหลือคงไม่ยากสำหรับทางโฮสต์แล้วค่ะ ขอบคุณนะคะ

ยังไงก็ยังรอคำตอบจากทุกๆ ท่านที่มีความรู้ด้านนี้อยู่นะคะ ขอบคุณมากๆ ค่ะ

ออฟไลน์ GB_LOVE

  • Ju
  • *
  • กระทู้: 18
  • เห็นด้วย&ขอบคุณ: 2
Re: upgrade smf 1.1 RC2 เป็น 1.1.5 แล้วเกิดข้อผิดพลาดค่ะ
« ตอบกลับ #20 เมื่อ: 27, สิงหาคม 2008, 03:19:56 AM »
แวะเข้ามาบอกข่าวดีค่ะ ตอนนี้แก้ไขได้แล้วค่ะ

พอดีนึกขึ้นได้ว่าก่อนอัพเกรดบอร์ดเคยใส่โค้ดที่โชว์ HP กับ Level  ไว้ พออัพเกรดแล้วโค้ดมัน error ค่ะ เลยลบโค้ดพวกนั้นออก ตอนนี้บอร์ดใช้ได้ตามเดิมแล้วค่ะ ขอบคุณทุกๆ ท่านมากๆ นะคะสำหรับคำแนะนำ  :adore: :adore:

Single

  • บุคคลทั่วไป
Re: upgrade smf 1.1 RC2 เป็น 1.1.5 แล้วเกิดข้อผิดพลาดค่ะ
« ตอบกลับ #21 เมื่อ: 27, สิงหาคม 2008, 01:41:49 PM »
อ่า..ใน Display.template.php เรียกใช้งาน function  $cr calRpg($cp);

แต่ใน Sources/Load.php ไม่มี

เพิ่มอันนี้ไว้หลังบรรทัดแรกของไฟล์ Sources/Load.php

///////////////
// DtTvB RPG //
///////////////
$rpgSettings = array();
$rpgSettings['init'] = 5;
$rpgSettings['incre'] = 3;
function 
calRpg($p) {
   global 
$rpgSettings;
   
$i 0$j $rpgSettings['init']; $l 0;
   while (
$i $p) {
      
$l++;
      
$i += $j;
      
$j += $rpgSettings['incre'];
   }
   
$fn $i;
   
$cbase = ($i - ($j $rpgSettings['incre']));
   if (
$l 1$l 1;
   
$pc = (($p $cbase) / ($fn $cbase)) * 100;
   if (
$pc >= 100) { $pc=0$l++; }
   return array(
      
'level' => $l,
      
'cbase' => $cbase,
      
'nbase' => $fn,
      
'perce' => $pc
   
);
}


ใน Themes/Display.template.php

เพิ่ม global $db_prefix;

หลัง function template_main()
{


ประมาณบรรทัดที่ 5-6

ต่อจากนั้นก็เพิ่มโค๊ด HP & Level ได้เลย

ออฟไลน์ GB_LOVE

  • Ju
  • *
  • กระทู้: 18
  • เห็นด้วย&ขอบคุณ: 2
Re: upgrade smf 1.1 RC2 เป็น 1.1.5 แล้วเกิดข้อผิดพลาดค่ะ
« ตอบกลับ #22 เมื่อ: 28, สิงหาคม 2008, 11:25:52 AM »
ขอคุณคุณ single ด้วยนะคะ ตอนนี้โค้ด hp กับ level ใช้การได้แล้วค่ะ  :smitten:

 

Sitemap 1 2 3 4 5 6 7 8 9 10 
Back to top