Home Webboard ArticlesKnowledges  

ผู้เขียน หัวข้อ: จะ UP จาก version 1.1.5 เป็น 1.1.6 ต้องทำยังไงมั่งค่ะ (มือใหม่ค่ะ)  (อ่าน 26695 ครั้ง)

0 สมาชิก และ 1 บุคคลทั่วไป กำลังดูหัวข้อนี้

ออฟไลน์ ก๊วนกวน

  • Just Staff
  • *
  • กระทู้: 402
  • เห็นด้วย&ขอบคุณ: 21
    • pop music box
อัพเดทผ่านหน้าเวป
ผ่านไปแล้ว
สำเร็จแต่ตัวเลข

ไม่เปลี่ยนยัง 1.1.5 เหมือนเดิมนี่คิดว่าอัพสำเร็จไหมครับ


เขาไปแก้ใน _setting อะไรนี่แก้ตรงไหนครับ เข้าไปดาต้าเบส _setting ไม่เห็นมีตรงไหนให้แก้เลยครับ

 :smitten-1: แล้วตรงไหนมัน 1.1.5 ตรงไหน 1.1.6 อ่ะ สักงง อัพแล้วเหมือนกันอ่ะ ครับ  :crying:
จงเต้น  โดยคิดว่าไม่มีใครมองอยู่
จงรัก    โดยคิดว่าจะไม่ได้รับความเจ็บปวดเลยซักครั้ง
จงร้องเพลง  โดยคิดว่าไม่มีใครกำลังฟังอยู่
จงทำงาน     โดยคิดว่าไม่ต้องการเงิน
จงใช้ชีวิต     โดยคิดว่าวันนี้เป็นวันสุดท้าย >> Series :: เรื่อง My Name is Kim Sam Soon

noname

  • บุคคลทั่วไป
ไม่สำเร็จครับ ถ้าสำเร็จตัวเลขเวอร์ชั่นจะเปลื่ยนเลย

ส่วนในตาราง _setting เลือกทั้งหมดแล้วเปิดดู จะเห็น column แรกเลย SMF version

ออฟไลน์ Game-Mun

  • wAtAsHiwA LianG DeS
  • Ju
  • *
  • กระทู้: 39
  • เห็นด้วย&ขอบคุณ: 6
  • เพศ: ชาย
    • Game-Mun.com
ขอบคุณมากนะครับที่แนะนำ ไม่งั้นคงยังไม่ได้ up ซักที ไปเจอมาหลายวิธี แต่วิธีที่ง่ายที่สุดคือ กด

ปรับปรุงฟอรัม ที่บอร์ดเราได้เลยครับ

ตอนแรกผมใช้ 1.1.4 กดทีเนิง มันปรับให้เป็น 1.1.5 แล้วกดอีกทีมาเป็น 1.1.6

ออฟไลน์ june5555

  • Ju
  • *
  • กระทู้: 29
  • เห็นด้วย&ขอบคุณ: 2
ขอบพระคุณมากๆค่ะ แต่ขอเวลาทำใจก่อนนะค่ะกลัวทำพังอะค่ะ :smitten-1:

ออฟไลน์ Game-Mun

  • wAtAsHiwA LianG DeS
  • Ju
  • *
  • กระทู้: 39
  • เห็นด้วย&ขอบคุณ: 6
  • เพศ: ชาย
    • Game-Mun.com
ขอบพระคุณมากๆค่ะ แต่ขอเวลาทำใจก่อนนะค่ะกลัวทำพังอะค่ะ :smitten-1:

กลัวบอร์ดจะพัง ช่วงที่มันจะ update ให้ อ่านดู มันจะมีคำว่าสำเร็จ ถ้าไฟล์ไหนขึ้นว่าไม่สำเร็จ ให้เราอย่าเพิ่งทำการ upgrade แล้วให้เราไป copy file นั้นออกมา

backup ไว้ก่อนครับ แต่ถ้ามันขึ้นสำเร็จก็กดไปได้เลยครับ ผมก็เสียวบอร์ดพัง แต่ bug ที่เจอนั้นร้ายแรงเลยตัดสินใจ up ไปดีกว่า

ผมไม่แน่ใจเหมือนกันว่า การ upgrade มันไปเปลี่ยนแปลงที่ DB รึเปล่า แต่ถ้าเปลี่ยนแปลงแค่ไฟล์ในเวปก็ไม่น่าจะมีปัญหา

ออฟไลน์ june5555

  • Ju
  • *
  • กระทู้: 29
  • เห็นด้วย&ขอบคุณ: 2
 :boxing: เด๋วจะลองดูค่ะ ขอบคุณค่ะ

ออฟไลน์ july8329

  • Ju
  • *
  • กระทู้: 85
  • เห็นด้วย&ขอบคุณ: 3
  • เพศ: ชาย
    • ROMATHAI FANSITE
อัพจาก 1.1.5 ผ่านหน้าเว็บเป็น 1.1.6 สำเร็จแล้ว แค่นี้ก้ไม่ต้องไปแก้ตรงไหนอีกแล้วใช่มั้ยครับ

ออฟไลน์ เซียวเหล่งนึ่งฯ

  • Global Moderator
  • *
  • กระทู้: 5547
  • เห็นด้วย&ขอบคุณ: 2148
    • SMFjusthost.com
อัพจาก 1.1.5 ผ่านหน้าเว็บเป็น 1.1.6 สำเร็จแล้ว แค่นี้ก้ไม่ต้องไปแก้ตรงไหนอีกแล้วใช่มั้ยครับ

5+ ตามนั้นเลย

ออฟไลน์ ตองคิง

  • คนไทย หัวใจเต็มร้อย
  • Ju
  • *
  • กระทู้: 7
  • เห็นด้วย&ขอบคุณ: 3
ผมลอง FTP ตัวอัพขึ้นไปแล้วค่อย set ทำได้นะครับ
แต่ต้องแก้ ไฟล์ upgrade_1-1.sql
ตรงบรรทัด 181

จาก
ORDER BY LENGTH(code) DESC;

เป็น
ORDER BY smileyOrder;

ผ่านครับใช้อยู่ ไม่มีปัญหา
ลองดูครับ
ถ้าจะให้ชัวร์ แบคอัพ อันเดิมไว้ก่อนนะครับ
รักไอที วันละนิด จิตแจ่มใส

ออฟไลน์ atthasard

  • Ju
  • *
  • กระทู้: 15
  • เห็นด้วย&ขอบคุณ: 4
ทราบว่าพอเรากดที่ ปรับปรุงฟอรั่ม แล้วมันไม่ผ่าน บางอย่างมันขึ้นมาบอกว่า ไม่สำเร็จหรืออะไรสักอย่างนี้หล่ะ แต่บางก็สำเร็จ ใครมีวิธีช่วยแนะนำหน่อยคับ พอดีใหม่ อ่ะคับ แนะนำด้วยน่ะคับ

ออฟไลน์ เซียวเหล่งนึ่งฯ

  • Global Moderator
  • *
  • กระทู้: 5547
  • เห็นด้วย&ขอบคุณ: 2148
    • SMFjusthost.com
อ้างถึง
ข้อผิดพลาดนี้อาจจะมีสาเหตุโดยขัดกันระหว่างแพ็คเกจที่พยายามติดตั้ง และแพ็คเกจอื่นๆ ที่ได้ติดตั้งแล้ว

ความหมายมันก็ชัดเจนอยู่แล้วครับ หากไม่ต้องการให้เกิดปัญหานี้ smf ที่คุณใช้ไม่ต้องติดตั้ง mod หรือปรับแต่งใดๆ ทั้งสิ้น เพราะถ้าหากคุณติดตั้ง mod หรือปรับแต่งใดๆ ในไฟล์ส่วนที่การอัพเกรดต้องการแก้ไข แต่ถูกแก้ไขโดย mod อื่นไปก่อนหน้านี้แล้วมันก็จะเกิดเหตุการแบบนี้แหละครับ ไม่จำเป็นต้องเป็นโฮสต์จริง localhost ก็เป็นเหมือนกัน

- อัพจากอะไร ไปอะไร อัพข้ามเวอร์ชั่นมากๆ มันก็ทำไม่ได้ ต้องรุ่นต่อรุ่นถึงจะได้
ถ้าจะข้ามรุ่นก็ยกไฟล์ทับเลย ง่ายกว่า

- ไม่ผ่าน ไม่สำเร็จ เพราะไม่ได้เปอมิสชั่นไฟล์ที่มันจะแก้เป็น 777  พอไม่เปอมันกั็เขียนทับไฟล์นั้นไม่ได้ 

- ไม่ผ่านเพราะไฟล์นั้นๆ มีการแก้ไขจากการลงม็อด หรือโมเอง ยำเองไปแล้ว  มันเลยหาจุดที่จะแก้ในไฟล์นั้นๆไม่เจอ

ที่ไม่ผ่านก็จะมีแค่นี้แหละ
เว็บที่ปรับปรุงแล้วผ่านเลย ส่วนใหญ่จะเป็นแบบเดิมๆไม่มีโมอะไรเลย

ออฟไลน์ atthasard

  • Ju
  • *
  • กระทู้: 15
  • เห็นด้วย&ขอบคุณ: 4
อ้างถึง
ข้อผิดพลาดนี้อาจจะมีสาเหตุโดยขัดกันระหว่างแพ็คเกจที่พยายามติดตั้ง และแพ็คเกจอื่นๆ ที่ได้ติดตั้งแล้ว

ความหมายมันก็ชัดเจนอยู่แล้วครับ หากไม่ต้องการให้เกิดปัญหานี้ smf ที่คุณใช้ไม่ต้องติดตั้ง mod หรือปรับแต่งใดๆ ทั้งสิ้น เพราะถ้าหากคุณติดตั้ง mod หรือปรับแต่งใดๆ ในไฟล์ส่วนที่การอัพเกรดต้องการแก้ไข แต่ถูกแก้ไขโดย mod อื่นไปก่อนหน้านี้แล้วมันก็จะเกิดเหตุการแบบนี้แหละครับ ไม่จำเป็นต้องเป็นโฮสต์จริง localhost ก็เป็นเหมือนกัน

- อัพจากอะไร ไปอะไร อัพข้ามเวอร์ชั่นมากๆ มันก็ทำไม่ได้ ต้องรุ่นต่อรุ่นถึงจะได้
ถ้าจะข้ามรุ่นก็ยกไฟล์ทับเลย ง่ายกว่า

- ไม่ผ่าน ไม่สำเร็จ เพราะไม่ได้เปอมิสชั่นไฟล์ที่มันจะแก้เป็น 777  พอไม่เปอมันกั็เขียนทับไฟล์นั้นไม่ได้ 

- ไม่ผ่านเพราะไฟล์นั้นๆ มีการแก้ไขจากการลงม็อด หรือโมเอง ยำเองไปแล้ว  มันเลยหาจุดที่จะแก้ในไฟล์นั้นๆไม่เจอ

ที่ไม่ผ่านก็จะมีแค่นี้แหละ
เว็บที่ปรับปรุงแล้วผ่านเลย ส่วนใหญ่จะเป็นแบบเดิมๆไม่มีโมอะไรเลย



จาก 1.1.4 ไป 1.1.5 คับ มันมีปัญหา พอคลิก ที่ ปรับปรุงฟอรั้ม แล้ว ก็เกิดล้มเหลม ในบางหัวขึ้น คับ

ออฟไลน์ เซียวเหล่งนึ่งฯ

  • Global Moderator
  • *
  • กระทู้: 5547
  • เห็นด้วย&ขอบคุณ: 2148
    • SMFjusthost.com
งั้นก็เมนวลเอง อัพมือ

 

Sitemap 1 2 3 4 5 6 7 8 9 10 
Back to top