Home Webboard ArticlesKnowledges  

ผู้เขียน หัวข้อ: อยากเอา new ไปใส่ต่อท้ายหัวข้อใหม่เราต้องไปกำหนดยังไงคับ  (อ่าน 31513 ครั้ง)

0 สมาชิก และ 1 บุคคลทั่วไป กำลังดูหัวข้อนี้

ออฟไลน์ bomb

  • Just Staff
  • *
  • กระทู้: 400
  • เห็นด้วย&ขอบคุณ: 27
  • เพศ: ชาย
    • IT-CLUB เว็บไซต์เพื่อการเรียนรู้
ต้องการรูป เช่น รูปนี้ของเว็บ just ไปใส่ต่อท้ายกระทู้ใหม่อ่ะคับ


ผมไปแก้ไขที่ \Theme\default\language\Manual.thai.php

ผมแก้ตรงส่วนนี้คับ

โค๊ด: [Select]
$txt['manual_index_views'] = 'อ่าน';
$txt['manual_index_last_post'] = 'กระทู้ล่าสุด';
$txt['manual_index_topic_subject'] = 'หัวข้อกระทู้';
$txt['manual_index_new'] = 'ใหม่';
$txt['manual_index_topic_starter'] = 'ผู้ตั้งหัวข้อ';
$txt['manual_index_last_poster'] = 'วันที่, เวลา และผู้ตั้งกระทู้ล่าสุด';
$txt['manual_index_normal_post'] = 'ข้อความของคุณอยู่ในหัวข้อนี้';

แก้เป็นอย่างงี้คับ และผมก็เอาไฟล์ รูปภาพ ของผมไปใส่ไว้ที่ \Theme\IT-CLUB\images\icons\new_post.gif
โค๊ด: [Select]
$txt['manual_index_views'] = 'อ่าน';
$txt['manual_index_last_post'] = 'กระทู้ล่าสุด';
$txt['manual_index_topic_subject'] = 'หัวข้อกระทู้';
<img src="', $txt['manual_index_new'], '/icons/new_post.gif" alt="', $txt[34], '" />
$txt['manual_index_topic_starter'] = 'ผู้ตั้งหัวข้อ';
$txt['manual_index_last_poster'] = 'วันที่, เวลา และผู้ตั้งกระทู้ล่าสุด';
$txt['manual_index_normal_post'] = 'ข้อความของคุณอยู่ในหัวข้อนี้';

<img src="', $txt['manual_index_new'], '/icons/new_post.gif" alt="', $txt[34], '" /> //แก้

ไม่ทราบว่าผมแก้ถูกรึเปล่าคับ  ทำไมมันไม่โชว์  หรือเป็นเพราะว่ามันเก่าแล้ว แต่ผมเพิ่งโพสเองคับ มันมีหลักการนับยังไงที่ทำให้ มันหายไปคับ
« แก้ไขครั้งสุดท้าย: 09, เมษายน 2008, 12:30:45 PM โดย bomb »


-= ประเทศไทย ไม่ได้ขึ้นอยู่กับใครสองคน =-
สังคมไทยจะดีขึ้นถ้าคนไทย  รู้จักแบ่งปันสิ่งดีๆให้แก่กัน

Single

  • บุคคลทั่วไป
แก้ที่ Thems/MessageIndex.template

ส่วนนี้..


โค๊ด: [Select]
// Is this topic new? (assuming they are logged in!)
if ($topic['new'] && $context['user']['is_logged'])
echo '
<a href="', $topic['new_href'], '" id="newicon' . $topic['first_post']['id'] . '"><img src="', $settings['images_url'], '/', $context['user']['language'], '/new.gif" alt="', $txt[302], '" /></a>';


เอารูปไปใส่ Theme/IT-CLUB/images

มันจะแสดงก็ต่อเมื่อกระทู้นั้น ๆ เรายังไม่ได้อ่าน..

พอเราอ่านแล้วหรือเปิดแล้วมันก็หายไป..แต่ถ้าเป็นกระทู้ของเราเอง..จะไม่ new

ออฟไลน์ bomb

  • Just Staff
  • *
  • กระทู้: 400
  • เห็นด้วย&ขอบคุณ: 27
  • เพศ: ชาย
    • IT-CLUB เว็บไซต์เพื่อการเรียนรู้
ถ้าเราไม่เห็นแล้วจะเช็คได้ยังไงคับว่ามันขึ้นหรือเปล่า
-= ประเทศไทย ไม่ได้ขึ้นอยู่กับใครสองคน =-
สังคมไทยจะดีขึ้นถ้าคนไทย  รู้จักแบ่งปันสิ่งดีๆให้แก่กัน

Single

  • บุคคลทั่วไป
ก็เห็นเวลาคนอื่นโพสไง..

หรือไม่ก็โพสเอง..แล้วลงทุนสมัครอีก user หนึ่งเป็น user ธรรมดา..

ที่จริงก็ควรมีไว้..เพราะ..เราจะได้รู้ว่าเวลาเข้าด้วย user ธรรมดาแล้ว..บอร์ดเราเป็นอย่างไร..

เข้าแต่ user admin เลยไม่รู้ปัญหาของ user ธรรมไปเลย..

ออฟไลน์ เซียวเหล่งนึ่งฯ

  • Global Moderator
  • *
  • กระทู้: 5535
  • เห็นด้วย&ขอบคุณ: 2134
    • SMFjusthost.com
อิอิ คิดมากกันจัง 
เราก็อบรูปไปโยนทับเลย
http://-----------/Themes/default/images/thai-utf8/new.gif

ออฟไลน์ bomb

  • Just Staff
  • *
  • กระทู้: 400
  • เห็นด้วย&ขอบคุณ: 27
  • เพศ: ชาย
    • IT-CLUB เว็บไซต์เพื่อการเรียนรู้
คือว่า Theme ที่ผมใช้มันไม่มีรูป new.gif อยู่อ่ะคับพอหัวข้อใหม่มันจะขึ้นเป็นข้อความว่า ใหม แทนคับ  :haha: :haha:
-= ประเทศไทย ไม่ได้ขึ้นอยู่กับใครสองคน =-
สังคมไทยจะดีขึ้นถ้าคนไทย  รู้จักแบ่งปันสิ่งดีๆให้แก่กัน

ออฟไลน์ เซียวเหล่งนึ่งฯ

  • Global Moderator
  • *
  • กระทู้: 5535
  • เห็นด้วย&ขอบคุณ: 2134
    • SMFjusthost.com
จริงแฮะ 55  แว๊บไปดูมา

Single

  • บุคคลทั่วไป
ถ้าธีมโม..ต้องแก้ตามที่บอกนั่นแหละค่ะ..

เอาโค๊ดนั้นไปวางทับ..ส่วนนั้นเลย..ธีมโมมันให้เรียก $txt ถ้าธีมมาตราฐานมันจะเรียก new.gif จากโฟลเดอร์ภาษา..

ท่าน bomb ลองตามนั้นเลยค่ะ..รับรองไม่ผิดหวัง..การันตี..

ออฟไลน์ bomb

  • Just Staff
  • *
  • กระทู้: 400
  • เห็นด้วย&ขอบคุณ: 27
  • เพศ: ชาย
    • IT-CLUB เว็บไซต์เพื่อการเรียนรู้
เย้ๆ ไปแก้จนได้แล้วคับ  :adore: :grin: :dev:
-= ประเทศไทย ไม่ได้ขึ้นอยู่กับใครสองคน =-
สังคมไทยจะดีขึ้นถ้าคนไทย  รู้จักแบ่งปันสิ่งดีๆให้แก่กัน

ออฟไลน์ LittleCat

  • ไม่เต็มบาท
  • Administrator
  • *
  • กระทู้: 1608
  • เห็นด้วย&ขอบคุณ: 432
  • ตามโลกไม่ทัน
    • บอร์ดแมวเมา
อย่าคิดว่าตนเองเก่ง อย่าคิดว่าคนอื่นขาดตนเองไม่ได้ -- หลักการในการทำงานของแมวขี้เมา

ออฟไลน์ july8329

  • Ju
  • *
  • กระทู้: 85
  • เห็นด้วย&ขอบคุณ: 3
  • เพศ: ชาย
    • ROMATHAI FANSITE
ของเอา [new] ไปใช้ด้วยนะครับ :smitten:

คนหลงทาง

  • บุคคลทั่วไป
 :smitten-1:  เพิ่มให้ครับ

 mod http:custom.simplemachines.org/mods/index.php?mod=1491 เพิ่ม newในหัวข้อ


Themes/default/Display.template.php

ค้นหา
โค๊ด: [Select]
<a href="', $message['href'], '">', $message['subject'], '</a>

วางโค๊ดนี้ทับที่ค้นหา
โค๊ด: [Select]
<a href="', $message['href'], '">', $message['subject'], '</a>';
// New message? If so, show the new.gif image after the message title, but not for guests.
if ($message['new'] && $context['user']['is_logged'])
echo '
<img src="', $settings['images_url'], '/', $context['user']['language'], '/new.gif" title="', $txt[302], '" alt="" />';
echo '

  :azn:

ออฟไลน์ euromous

  • Ju
  • *
  • กระทู้: 2
  • เห็นด้วย&ขอบคุณ: 2
แก้ที่ Thems/MessageIndex.template

พอดี theme ผมมันมีแค่ 2 files เองอะครับ คือ index.template.php และ BoardIndex.template.php
ผมพยายามเข้าไปหาในส่วนของ file BoardIndex แล้วแต่มันไ่ม่เหมือนกันเลยอะครับ

พอมีคำแนะนำไหมครับ ขอบคุณครับ  :smiley:

ออฟไลน์ ก๊วนกวน

  • Just Staff
  • *
  • กระทู้: 402
  • เห็นด้วย&ขอบคุณ: 21
    • pop music box
แก้ที่ Thems/MessageIndex.template

พอดี theme ผมมันมีแค่ 2 files เองอะครับ คือ index.template.php และ BoardIndex.template.php
ผมพยายามเข้าไปหาในส่วนของ file BoardIndex แล้วแต่มันไ่ม่เหมือนกันเลยอะครับ

พอมีคำแนะนำไหมครับ ขอบคุณครับ  :smiley:

แก้ในธีม default แล้วถ้าไม่ขึ้น ลอง เอารูปไปใส่ Theme/ธีมที่ใช้/images
จงเต้น  โดยคิดว่าไม่มีใครมองอยู่
จงรัก    โดยคิดว่าจะไม่ได้รับความเจ็บปวดเลยซักครั้ง
จงร้องเพลง  โดยคิดว่าไม่มีใครกำลังฟังอยู่
จงทำงาน     โดยคิดว่าไม่ต้องการเงิน
จงใช้ชีวิต     โดยคิดว่าวันนี้เป็นวันสุดท้าย >> Series :: เรื่อง My Name is Kim Sam Soon

ออฟไลน์ euromous

  • Ju
  • *
  • กระทู้: 2
  • เห็นด้วย&ขอบคุณ: 2
แก้ในธีม default แล้วถ้าไม่ขึ้น ลอง เอารูปไปใส่ Theme/ธีมที่ใช้/images

ขอบคุณนะครับ
แต่ใน Theme default ของผมก็มี code ในส่วนนี้อยู่แล้วครับ

แก้ที่ Thems/MessageIndex.template

ส่วนนี้..


โค๊ด: newbielink:javascript:void(0); [nonactive]
// Is this topic new? (assuming they are logged in!)
if ($topic['new'] && $context['user']['is_logged'])
echo '
<a href="', $topic['new_href'], '" id="newicon' . $topic['first_post']['id'] . '"><img src="', $settings['images_url'], '/', $context['user']['language'], '/new.gif" alt="', $txt[302], '" /></a>';


เอารูปไปใส่ Theme/IT-CLUB/images

แล้วผมก็ copy รูปไปใส่ใน Theme/ธีมที่ใช้/images ด้วยแล้วครับ
ประเด็นคือผมหาคำสั่งตรงที่มันอ่านค่าคำว่า "ใหม่" ขึ้นมาไม่เจอเลยอะครับ (ใน BoardIndex.template.php)

พอมีคำแนะนำหรือต้องการข้อมูลเพิ่มเติมไหมครับ รบกวนอีกครั้งครับ ขอบคุณครับ  :rolleyes:

 

Sitemap 1 2 3 4 5 6 7 8 9 10 
Back to top