Home Webboard ArticlesKnowledges  

ผู้เขียน หัวข้อ: ปัญหาภาษาไทย ใน SMF 2.0 RC1 (มีภาพ)  (อ่าน 46471 ครั้ง)

0 สมาชิก และ 1 บุคคลทั่วไป กำลังดูหัวข้อนี้

ออฟไลน์ kero

  • Ju
  • *
  • กระทู้: 14
  • เห็นด้วย&ขอบคุณ: 2
Re: ปัญหาภาษาไทย ใน SMF 2.0 RC1 (มีภาพ)
« ตอบกลับ #15 เมื่อ: 10, มีนาคม 2010, 09:14:02 AM »
ฮือ ปัญหาคือมันเป็นเฉพาะเดือน แต่ตัวอื่นๆกลับเป็นปกติสุข
งั้นตอนนี้ต้องดูว่าไฟล์ภาษาไทยของท่านใช้อะไร 
เป็น thai-utf8.php    หรือ    thai.php

เดือนไทยอยู่ในไฟล์นี้   index.thai-utf8.php
// Months must start with 1 => 'January'. (or translated, of course.)
$txt['months'] = array(1 => 'มกราคม','กุมภาพันธ์','มีนาคม','เมษายน','พฤษภาคม','มิถุนายน','กรกฎาคม','สิงหาคม','กันยายน','ตุลาคม','พฤศจิกายน','ธันวาคม');
$txt['months_titles'] = array(1 => 'มกราคม','กุมภาพันธ์','มีนาคม','เมษายน','พฤษภาคม','มิถุนายน','กรกฎาคม','สิงหาคม','กันยายน','ตุลาคม','พฤศจิกายน','ธันวาคม');
$txt['months_short'] = array(1 => 'ม.ค.','ก.พ.','มี.ค.','เม.ย.','พ.ค.','มิ.ย.','ก.ค.','ส.ค.','ก.ย.','ต.ค.','พ.ย.','ธ.ค.');

ถ้าโค๊ดเดือนมันยังปกติดีอยู่
ก็ต้องลองเอนโค๊ดไฟล์ภาษาดู 

อีกอย่างคือ ลองไปโหลดไฟล์ภาษามาทั้งสองแบบ  ทดลองทีละแบบ


ลองทำตามนี้ดูก่อน ถ้ายังไม่ได้ต้องรอดูคำแนะนำจากท่านโนเนมอีกที


ของผมใช้ เป็น thai-utf8.php    ครับ และเข้ไปดูแล้ว ปกติดีครับ เหมือนตัวอย่างที่โพสไว้นะครับ

==== ตัวอย่างนะครับ =====
// Again, SPELLING SHOULD BE '' 99% OF THE TIME!!  Please read this!
$txt['lang_locale'] = 'th_TH.utf8';
$txt['lang_dictionary'] = 'en';
$txt['lang_spelling'] = 'american';

// Character set and right to left?
$txt['lang_character_set'] = 'UTF-8';
$txt['lang_rtl'] = false;

$txt['days'] = array('อาทิตย์','จันทร์','อังคาร','พุธ','พฤหัสบดี','ศุกร์','เสาร์');
$txt['days_short'] = array('อา.','จ.','อ.','พ.','พฤ.','ศ.','ส.');
// Months must start with 1 => 'January'. (or translated, of course.)
$txt['months'] = array(1 => 'มกราคม','กุมภาพันธ์','มีนาคม','เมษายน','พฤษภาคม','มิถุนายน','กรกฎาคม','สิงหาคม','กันยายน','ตุลาคม','พฤศจิกายน','ธันวาคม');
$txt['months_titles'] = array(1 => 'มกราคม','กุมภาพันธ์','มีนาคม','เมษายน','พฤษภาคม','มิถุนายน','กรกฎาคม','สิงหาคม','กันยายน','ตุลาคม','พฤศจิกายน','ธันวาคม');
$txt['months_short'] = array(1 => 'ม.ค.','ก.พ.','มี.ค.','เม.ย.','พ.ค.','มิ.ย.','ก.ค.','ส.ค.','ก.ย.','ต.ค.','พ.ย.','ธ.ค.');


NoName

  • บุคคลทั่วไป
Re: ปัญหาภาษาไทย ใน SMF 2.0 RC1 (มีภาพ)
« ตอบกลับ #16 เมื่อ: 10, มีนาคม 2010, 12:41:26 PM »
Encoding ไฟล์ภาษาไทยทุกไฟล์เป็น UTF-8

ออฟไลน์ kero

  • Ju
  • *
  • กระทู้: 14
  • เห็นด้วย&ขอบคุณ: 2
Re: ปัญหาภาษาไทย ใน SMF 2.0 RC1 (มีภาพ)
« ตอบกลับ #17 เมื่อ: 10, มีนาคม 2010, 01:28:38 PM »
Encoding ไฟล์ภาษาไทยทุกไฟล์เป็น UTF-8

Encoding ที่ตัวไหนครับ (ทำไงอ่ะครับ ที่ Database หรือ ที่ไหนครับ ที่ Database ทำแล้วครับ)

unname

  • บุคคลทั่วไป
Re: ปัญหาภาษาไทย ใน SMF 2.0 RC1 (มีภาพ)
« ตอบกลับ #18 เมื่อ: 10, มีนาคม 2010, 03:14:21 PM »
Encoding ไฟล์ภาษาไทยทุกไฟล์เป็น UTF-8


Encoding ที่ตัวไหนครับ (ทำไงอ่ะครับ ที่ Database หรือ ที่ไหนครับ ที่ Database ทำแล้วครับ)


เข้าใจว่าต้อง encode ไฟล์ .php นะครับ

ใช้ editor ตัวที่ท่านใช้ (เช่น notepad) แล้ว save as ไปที่ไฟล์เดิม , กรอบ Save as... จะมีตัวเลือก Encoding: ให้เลือก ANSI, UNICODE



ส่วน editor อื่นๆ ก็จะเป็นไปตามที่โปรแกรมนั้นๆ ออกแบบมาครับ

:smitten-1:

ออฟไลน์ kero

  • Ju
  • *
  • กระทู้: 14
  • เห็นด้วย&ขอบคุณ: 2
Re: ปัญหาภาษาไทย ใน SMF 2.0 RC1 (มีภาพ)
« ตอบกลับ #19 เมื่อ: 10, มีนาคม 2010, 05:06:35 PM »
ลอง Endoce แล้วครับ ยังเหมือนเดิม ติดที่ตรง ชื่อ "เดือน" นะครับ

NoName

  • บุคคลทั่วไป
Re: ปัญหาภาษาไทย ใน SMF 2.0 RC1 (มีภาพ)
« ตอบกลับ #20 เมื่อ: 10, มีนาคม 2010, 05:26:11 PM »
ขอ URL ดูสถานที่จริงครับ

ออฟไลน์ kero

  • Ju
  • *
  • กระทู้: 14
  • เห็นด้วย&ขอบคุณ: 2
Re: ปัญหาภาษาไทย ใน SMF 2.0 RC1 (มีภาพ)
« ตอบกลับ #21 เมื่อ: 10, มีนาคม 2010, 06:15:38 PM »
ขอหลังไมด์ หรือขอ E-mail ติดต่อได้ไหม? ครับ หรือ ไม่รบกวนเกินไป เมลผมนะครับ  kiadturbo[แอท]hotmail.com ขอบคุณครับ

ออฟไลน์ เซียวเหล่งนึ่งฯ

  • Global Moderator
  • *
  • กระทู้: 5547
  • เห็นด้วย&ขอบคุณ: 2148
    • SMFjusthost.com
Re: ปัญหาภาษาไทย ใน SMF 2.0 RC1 (มีภาพ)
« ตอบกลับ #22 เมื่อ: 10, มีนาคม 2010, 06:25:49 PM »
ยูอาแอลบอร์ดท่าน จำเป็นนะ  (ดูที่กระทู้ปักหมุด)
ถ้าเว้บท่านล่อแหลม ผิดกฎ 18+ เราก็คงช่วยต่อไม่ได้

หรือหากเป็นเว็บองกร เว็บบริษัท ไม่อยากเปิดเผย ก็บอกได้ ค่อยว่ากันหลังไมค์

ออฟไลน์ kero

  • Ju
  • *
  • กระทู้: 14
  • เห็นด้วย&ขอบคุณ: 2
Re: ปัญหาภาษาไทย ใน SMF 2.0 RC1 (มีภาพ)
« ตอบกลับ #23 เมื่อ: 10, มีนาคม 2010, 06:51:06 PM »
ยูอาแอลบอร์ดท่าน จำเป็นนะ  (ดูที่กระทู้ปักหมุด)
ถ้าเว้บท่านล่อแหลม ผิดกฎ 18+ เราก็คงช่วยต่อไม่ได้

หรือหากเป็นเว็บองกร เว็บบริษัท ไม่อยากเปิดเผย ก็บอกได้ ค่อยว่ากันหลังไมค์

เป็นเวบอองค์กรนะครับ ไม่ผิดกฏ ลามกอนาจาร แน่นอนครับ

ออฟไลน์ เซียวเหล่งนึ่งฯ

  • Global Moderator
  • *
  • กระทู้: 5547
  • เห็นด้วย&ขอบคุณ: 2148
    • SMFjusthost.com
Re: ปัญหาภาษาไทย ใน SMF 2.0 RC1 (มีภาพ)
« ตอบกลับ #24 เมื่อ: 10, มีนาคม 2010, 06:53:04 PM »
งั้นส่งรายละเอียด ยูอาแอลเว็บ เอฟทีพี คอนโทรลพาแนล มาทางพีเอ็มเลย เดี๋ยวเราส่งต่อให้ท่านโนเนมให้

ออฟไลน์ เซียวเหล่งนึ่งฯ

  • Global Moderator
  • *
  • กระทู้: 5547
  • เห็นด้วย&ขอบคุณ: 2148
    • SMFjusthost.com
Re: ปัญหาภาษาไทย ใน SMF 2.0 RC1 (มีภาพ)
« ตอบกลับ #25 เมื่อ: 10, มีนาคม 2010, 09:22:02 PM »
ส่งยูอาแอลให้ท่านโนเนมไปแล้วหละ
โดยส่วนตัวถ้าไม่อยากคิดมาก คงเปลี่ยนเดือน จากตัวหนังสือเป็นตัวเลข  555+

NoName

  • บุคคลทั่วไป
Re: ปัญหาภาษาไทย ใน SMF 2.0 RC1 (มีภาพ)
« ตอบกลับ #26 เมื่อ: 10, มีนาคม 2010, 09:48:31 PM »
เข้าไปดูใน ผู้ดูแล >> ส่วน ปรับแต่งค่าการใช้งาน >> รูปแบบเวลาปกติ

ให้เป็นรูปแบบนี้นะครับ
โค๊ด: [Select]
%B %d, %Y, %I:%M:%S %p
หรือ
โค๊ด: [Select]
%e %B %Y, %H:%M:%S
ถ้าหากเป็น Windows Server เปลี่ยน %e เป็น %d นะครับ

ออฟไลน์ kero

  • Ju
  • *
  • กระทู้: 14
  • เห็นด้วย&ขอบคุณ: 2
Re: ปัญหาภาษาไทย ใน SMF 2.0 RC1 (มีภาพ)
« ตอบกลับ #27 เมื่อ: 10, มีนาคม 2010, 10:10:59 PM »
ส่งยูอาแอลให้ท่านโนเนมไปแล้วหละ
โดยส่วนตัวถ้าไม่อยากคิดมาก คงเปลี่ยนเดือน จากตัวหนังสือเป็นตัวเลข  555+

ขอบคุณมากครับ

ออฟไลน์ kero

  • Ju
  • *
  • กระทู้: 14
  • เห็นด้วย&ขอบคุณ: 2
Re: ปัญหาภาษาไทย ใน SMF 2.0 RC1 (มีภาพ)
« ตอบกลับ #28 เมื่อ: 10, มีนาคม 2010, 10:14:46 PM »
เข้าไปดูใน ผู้ดูแล >> ส่วน ปรับแต่งค่าการใช้งาน >> รูปแบบเวลาปกติ

ให้เป็นรูปแบบนี้นะครับ
โค๊ด: [Select] [nofollow]
%B %d, %Y, %I:%M:%S %p
หรือ
โค๊ด: [Select] [nofollow]
%e %B %Y, %H:%M:%S
ถ้าหากเป็น Windows Server เปลี่ยน %e เป็น %d นะครับ

ขอบคุณคุณ โนเนม มากครับ ผมได้ทำการแก้ไข รูปแบบเวลา เป็นทั้งสองแบบแล้วครับ แต่ว่า ผลยังเหมือนเดิมครับ  เดิมของผม เป็น ชุดแรกครับ 
โค๊ด: [Select] [nofollow]
%B %d, %Y, %I:%M:%S %p  ขอรบกวนอีกครั้งนะครับ

NoName

  • บุคคลทั่วไป
Re: ปัญหาภาษาไทย ใน SMF 2.0 RC1 (มีภาพ)
« ตอบกลับ #29 เมื่อ: 10, มีนาคม 2010, 10:39:07 PM »
คราวนี้น่าจะเป็นเพราะฐานข้อมูลแหละครับ

ต้องดูให้แน่ใจนะครับว่าทุกๆ ฟิลด์ที่มีการใช้อักขระได้ Encoding เป็น utf8_general_ci หมดแล้ว

การ Encoding ถ้าทำทั้งหมดใช้เวลาเป็นชั่วโมงนะครับไม่ใช่ทำแป๊บเดียว ต้องไล่ดูให้แน่ใจทุกๆ ฟิลด์เลย

 

Sitemap 1 2 3 4 5 6 7 8 9 10 
Back to top