Home Webboard ArticlesKnowledges  
ข่าวประกาศ:

:: กติกา มารยาท ในการใช้งานเว็บบอร์ด ::
กรุณากรอกอีเมล์จริงในการสมัคร และรับอีเมล์ยืนยันเพื่อใช้งานในบอร์ด

ผู้เขียน หัวข้อ: ปัญหารูป จำลองการตรวจสอบไม่แสดงครับ  (อ่าน 18162 ครั้ง)

0 สมาชิก และ 1 บุคคลทั่วไป กำลังดูหัวข้อนี้

ออฟไลน์ johnx

  • Ju
  • *
  • กระทู้: 14
  • เห็นด้วย&ขอบคุณ: 5
    • แต่งรูป.com
ปัญหาตอนสมัครสมาชิก รูปจำลองการตรวจสอบไม่แสดงครับ ถ้าเป็น ภาษา eng แสดงปกติดีครับ
แต่ถ้าเป็นภาษาไทย รูปมันจะไม่ขึ้น ครับ รบกวนหน่อยครับ
อาการตามรูปครับ
« แก้ไขครั้งสุดท้าย: 16, มีนาคม 2010, 11:04:56 AM โดย johnx »


[nofollow] [nofollow]

ออฟไลน์ เซียวเหล่งนึ่งฯ

  • Global Moderator
  • *
  • กระทู้: 5547
  • เห็นด้วย&ขอบคุณ: 2148
    • SMFjusthost.com

ออฟไลน์ johnx

  • Ju
  • *
  • กระทู้: 14
  • เห็นด้วย&ขอบคุณ: 5
    • แต่งรูป.com
Re: ปัญหารูป จำลองการตรวจสอบไม่แสดงครับ
« ตอบกลับ #2 เมื่อ: 16, มีนาคม 2010, 05:05:11 PM »
ขอแบบละเอียดสักนีสครับ ยังทำไม่ได้เลย
[nofollow] [nofollow]

ออฟไลน์ เซียวเหล่งนึ่งฯ

  • Global Moderator
  • *
  • กระทู้: 5547
  • เห็นด้วย&ขอบคุณ: 2148
    • SMFjusthost.com
Re: ปัญหารูป จำลองการตรวจสอบไม่แสดงครับ
« ตอบกลับ #3 เมื่อ: 16, มีนาคม 2010, 05:41:33 PM »
เครดิต zone-it.com


http://www.zone-it.com/48600
ใช้ตามข้อ 2 นะ
เพราะเป็นปัญหาที่ภาษาไทย

มีสองอย่าง

๑. เช็คดูว่า Host เปิด GD หรือเปล่า
๒. ไฟล์ภาษามีปัญหา คงจะไปใช้ UTF-8 with BOM ลองเปลี่ยนไปใช้ภาษาอังกฤษดู ถ้าหาย ก็ให้แก้ไฟล์ภาษาไทยกลับเป็น UTF-8 without BOM


แล้วเราจะแก้ไขตามข้อสองอย่างไงหรือ ตรงภาษานี้ แก้ไขที่ไฟล์ไหนหรือ

ข้อ1 รู้สึกว่าเขียน <? phpinfo(); ?> แล้วเอาไปรันดูน่าจะรู้


ตามข้อ1สาเหตุมาจาก host ไม่มี GD lib มารองรับทำให้ไม่สามารถสร้างภาพได้

ข้อ2. เปิด notepad++(plus plus นะ )หรือ edit plus เลือก encode UTF-8 without BOM

ตามข้อ2สาเหตุคือ ดึงไฟล์จาก host ,าแก้แล้วเซฟเป็น UTF-8 ทำให้ตัวโปรแกรมมันแทรกheader ลงไปในไฟล์แล้วทีนี้ phpจะส่งheader ไม่ได้
Notepad++ หาตาม GooGle คงไม่ยาก เป็น OpenSource แจกฟรีขอรับ(ส่วน editplus นั่นไม่แน่ใจเหมือนกันว่าจะมี without BOM รึเปล่า)

ถ้ายังไม่กระจ่าง ลองsearch หาดูที่ simplemachines.org forum ดูนะ(ปะกิด)





ดูตามไม่เจอทางแก้สักทาง สุดท้ายเจอและ

ไฟล์ Modifications.thai-utf8.php Saveโค้ดเป็นแบบ  ANSI แล้วอัพขึ้นโฮล ครับได้เลย








<?php
/*
UTF-8 BOM Scanner 
  By SvZ
*/

$path './Themes/default/languages/';

$dir opendir($path);
  echo 
'<h1>'.$path.'</h1>';

  while (
$f readdir($dir)) {

     if (
$f == '.' || $f == '..') continue;

     echo 
'<span style="color:'.(substr(file_get_contents($path.$f), 03) == "\xEF\xBB\xBF"?'red':'green').'">'.$f.'<br />';

}

closedir($dir);

?>

เซฟเป็น .php แล้วไปวางที่เดียวกับ SSI.php
ลองดูผล ถ้าไฟล์ไหนสีแดงแสดงว่าไฟล์นั้นมี utf-8 bom
วิธีแก้ก็ตามกระทู้นั้น

ออฟไลน์ johnx

  • Ju
  • *
  • กระทู้: 14
  • เห็นด้วย&ขอบคุณ: 5
    • แต่งรูป.com
Re: ปัญหารูป จำลองการตรวจสอบไม่แสดงครับ
« ตอบกลับ #4 เมื่อ: 17, มีนาคม 2010, 02:05:07 PM »
ขอบคุณครับกำลังลองทำอยู่  ได้ผลยังไงจะบอกอีกทีนะครับ
[nofollow] [nofollow]

ออฟไลน์ panyamobile

  • Ju
  • *
  • กระทู้: 14
  • เห็นด้วย&ขอบคุณ: 2
Re: ปัญหารูป จำลองการตรวจสอบไม่แสดงครับ
« ตอบกลับ #5 เมื่อ: 02, เมษายน 2010, 08:29:08 PM »
แก้ปัญหาไม่ได้เหมือนกัน เหนื่อยเลย

ออฟไลน์ minniesdg

  • Ju
  • *
  • กระทู้: 2
  • เห็นด้วย&ขอบคุณ: 2
    • elliptical trainer
Re: ปัญหารูป จำลองการตรวจสอบไม่แสดงครับ
« ตอบกลับ #6 เมื่อ: 03, เมษายน 2010, 02:35:52 AM »
แก้ยากจริงๆค่ะ
*Link Removed**Link Removed**Link Removed*

ออฟไลน์ panyamobile

  • Ju
  • *
  • กระทู้: 14
  • เห็นด้วย&ขอบคุณ: 2
Re: ปัญหารูป จำลองการตรวจสอบไม่แสดงครับ
« ตอบกลับ #7 เมื่อ: 03, เมษายน 2010, 11:55:59 AM »
ทำตามจนเว็บกลายเป็นภาษาต่างดาวเลย สงสัยจะทำไม่ถูกวิธี

ออฟไลน์ panyamobile

  • Ju
  • *
  • กระทู้: 14
  • เห็นด้วย&ขอบคุณ: 2
Re: ปัญหารูป จำลองการตรวจสอบไม่แสดงครับ
« ตอบกลับ #8 เมื่อ: 03, เมษายน 2010, 02:59:28 PM »
ส่งให้เพื่อน 20 กว่าคนแล้วครับรูปก็ไม่โชว์ตอนสมัคร แก้ยังไงผมจนปัญญาจริงๆครับ
ใครรู้ช่วยผมด้วยครับ เวปผมลองทำขึ้นเพื่อศึกษานะครับ ถ้าทำอะไรผิดก็ขอโทษด้วยครับ
นี่เวปผมครับ www.thai-mobile-online.com [nofollow] ช่วยผมด้วยได้โปรด ขอบคุณทุกท่านที่ให้การช่วยเหลือครับ

ออฟไลน์ เซียวเหล่งนึ่งฯ

  • Global Moderator
  • *
  • กระทู้: 5547
  • เห็นด้วย&ขอบคุณ: 2148
    • SMFjusthost.com
Re: ปัญหารูป จำลองการตรวจสอบไม่แสดงครับ
« ตอบกลับ #9 เมื่อ: 07, เมษายน 2010, 01:01:45 AM »
มีคุยกับทางโฮสตืรึยัง  เปิด GD

ออฟไลน์ panyamobile

  • Ju
  • *
  • กระทู้: 14
  • เห็นด้วย&ขอบคุณ: 2
Re: ปัญหารูป จำลองการตรวจสอบไม่แสดงครับ
« ตอบกลับ #10 เมื่อ: 22, เมษายน 2010, 06:46:15 PM »
น่าจะไปปรับแต่งอะไรพลาดครับ ผมลบทุกอย่างแล้วอัพเข้าใหม่ก็ได้แล้วครับ
ขอบคุณมากครับเว็บนี้มีประโยชน์มากเลยครับ มาดูและได้ข้อแก้ไขปัญหาจากเว็บนี้ มากพอสมควร

ถนัด

  • บุคคลทั่วไป
Re: ปัญหารูป จำลองการตรวจสอบไม่แสดงครับ
« ตอบกลับ #11 เมื่อ: 07, มิถุนายน 2010, 08:50:40 PM »
เอาความรู้มาฝาก พอดีผมเจอปัญหานี้มานานพอสมควร หลังจากอัพเดทจาก 1.1.10 เป็น 1.1.11 พยายามหาทางแก้มานาน วันนี้ไปไล่ดู format ของไฟล์ใน theme ที่ใช้อยู่มีไฟล์นึงคือ index.template ปรากฏว่าไฟล์เป็น UTF-8 + Bom ผมเลยลองดึงมาเซฟใหม่เป็น UTF-8 แล้วส่งกลับไป คราวนี้หายเลยครับ กลับมาเหมือนเดิมทุกอย่าง

ออฟไลน์ jackonthe

  • Ju
  • *
  • กระทู้: 1
  • เห็นด้วย&ขอบคุณ: 1
Re: ปัญหารูป จำลองการตรวจสอบไม่แสดงครับ
« ตอบกลับ #12 เมื่อ: 31, สิงหาคม 2010, 05:04:36 PM »
ขอบคุณครับ :yaahoo:
 *ขออภัย จำกัดสิทธิ์การใส่ Link-URL ในลายเซ็น*

ออฟไลน์ ree48012

  • ไม่มีคำว่าที่เดิมถ้าเราได้เริ่มต้น
  • Ju
  • *
  • กระทู้: 7
  • เห็นด้วย&ขอบคุณ: 4
  • เพศ: หญิง
    • http://www.newstalkten.com/
Re: ปัญหารูป จำลองการตรวจสอบไม่แสดงครับ
« ตอบกลับ #13 เมื่อ: 04, มิถุนายน 2011, 12:12:12 PM »
ไม่มีไฟล์ไหนสีแดง รูปก็ยังไม่ขึ้นอยู่ดีค่ะ
ไม่มีคำว่าแพ้ หากเราได้เริ่ม ไม่มีคำว่าอยู่ที่เดิมถ้าเราได้ค้นหา ไม่มีคำว่าที่หนึ่งหากเราต้องพึงพา ไม่มีคำว่าดีคกว่า หากเราไม่ตั้งใจ

ออฟไลน์ zelda

  • Just Staff
  • *
  • กระทู้: 474
  • เห็นด้วย&ขอบคุณ: 543
  • เพศ: ชาย
    • www.izedzine.com
Re: ปัญหารูป จำลองการตรวจสอบไม่แสดงครับ
« ตอบกลับ #14 เมื่อ: 04, มิถุนายน 2011, 12:32:21 PM »

ได้แก้ไฟล์ภาษาไทยหรือพิมพ์ภาษาไทยลงในไฟล์ไหนหรือเปล่าครับ
ถ้าใช่ เวลาแก้ให้เซฟเป็น UTF8 without Bom ด้วย (เปิดด้วย Notepad++ หรือ EditPlus ก็ได้)

 

Sitemap 1 2 3 4 5 6 
Back to top