Home Webboard ArticlesKnowledges  

Welcome to       :: JustUsers.net ::       การให้ ... คือสิ่งที่เรามีเหมือนกัน       กลับมารับใช้เพื่อนๆ เหมือนเดิมตลอดไป....!!    

ผู้เขียน หัวข้อ: Google +1  (อ่าน 2412 ครั้ง)

0 สมาชิก และ 1 บุคคลทั่วไป กำลังดูหัวข้อนี้

ออฟไลน์ Tcomputer

  • Just Staff
  • *
  • ID : 8536
  • กระทู้: 600
  • เห็นด้วย&ขอบคุณ: 503
Google +1
« เมื่อ: 10 กันยายน 2555, 21:49:37 น. »
ผมลง Mod Google +1 ซึ่งก็ใช้งานได้ปกติ แต่ไม่นานมานี้ ปัญหาเกิดขึ้นครับ คือ ถ้าใช้ Firefox มาเปิดในกระทู้ จะมองไม่เห็นปุ่ม Google +1 แต่ถ้าเรารีเฟรชครั้งสองครั้ง ปุ่ม Google+1 ก็ถึงจะแสดงผลเป็นปกติ  แต่ถ้าใช้ Browser Google Chrome ก็จะแสดงปกติ แต่คราวนี้ ผมลองอีกเว็บซึ่งลงโค๊ตเดียวกัน ใช้ Firefox เปิดก็เจอเลย ผมเลยไม่เข้าใจว่า ปัญหาอยู่ที่โค๊ต หรืออยู่ที่ไหนกันแน่นะครับผม ก่อนที่จะอาการนี้ผมลงโค้ดแสดงเวลาโพส เป็น วินาที นาที ชั่วโมง  ซึ่งไม่น่าจะเกี่ยวข้อง เพราะผมลองเอาออกแล้วก็มีอาการเหมือนเดิม เลยขอผู้รู้ช่วยวิเคราะห์สักนิดครับ ปัญหาเกิดจากอะไร




ออฟไลน์ เซียวเหล่งนึ่งฯ

  • Global Moderator
  • *
  • ID : 8
  • กระทู้: 5547
  • เห็นด้วย&ขอบคุณ: 2201
    • SMFjusthost.com
Re: Google +1
« ตอบกลับ #1 เมื่อ: 11 กันยายน 2555, 10:42:24 น. »
ลองถอดม็อดออกแล้วจับมันยัดเข้าไปดื้อๆในดีสเพลเทมเพลทเลย

โค๊ด: [เลือก]
if ($message['id'] == $context['topic_first_message'] )
{
echo '
<g:plusone href="' . $scripturl . '?topic=' . $context['current_topic'] . '" size="middle"></g:plusone>
<script type="text/javascript" src="http://apis.google.com/js/plusone.js"></script>';

** อีกความเป็นไปได้ คือดูค่าการเก็บแคชไฟล์ของบอร์ดเราว่าตั้งไว้แบบไหน
เพราะกูเกิล+ มันดึงโค๊ดและรูปมาจากเว็บภายนอก

** อีกความเป็นไปได้คือการเก็บเท็มไฟล์ของหมาย่างในเครื่องเรา
ต้องลองไปใช้เครื่องอื่นเข้าหมาย่างดู



ออฟไลน์ Tcomputer

  • Just Staff
  • *
  • ID : 8536
  • กระทู้: 600
  • เห็นด้วย&ขอบคุณ: 503
Re: Google +1
« ตอบกลับ #2 เมื่อ: 11 กันยายน 2555, 12:40:49 น. »
โค๊ต ผมลงด้วยมือครับป้าตุ่ ก็โค๊ตเดียวกันกับป้าตู่แนะนำมาครับ ส่วน แคช  ตรงระดับแคช ก็กำหนดไม่มีแคชครับ ส่วนการเก็บเทมไฟล์ คือมันเป็นทุกเครื่องเลยนะครับผม เพราะสมาชิกท่านอื่นๆ ผมให้ลองเข้าไปดูก็ปรากฎว่า เป็นเหมือนกัน ต้องรีเฟรชก่อนถึงจะเห็น ผมเลย งง ว่าสาเหตุเพราะอะไร

ออฟไลน์ Tcomputer

  • Just Staff
  • *
  • ID : 8536
  • กระทู้: 600
  • เห็นด้วย&ขอบคุณ: 503
Re: Google +1
« ตอบกลับ #3 เมื่อ: 12 กันยายน 2555, 05:26:30 น. »
ขอบคุณป้าตุ่มากนะครับ ผมแก้ไขได้แล้วครับผม
คือในไฟล์ index.template.php ผมไปลบ ส่วนนี้ออกครับ <script type="text/javascript" src="http://apis.google.com/js/plusone.js"></script>
ก็แสดงผลได้เลยใน Firefox แต่ก็ยังไม่หายสงสัย ตรงที่ ก่อนหน้านี้มันก็ใช้งานได้ปกติ ซึ่งก็มีสคริปตัวนี้ แต่ตอนที่มีปัญหา มันไม่แสดง  :razz: ได้แบบ งงๆ เผื่อสมาชิกท่านอื่นเป็นเหมือนผมก็ลองทำดูนะครับ

 
ชื่อ: อีเมล์:
ยืนยัน:
จงเขียนชื่อจังหวัด "กานจะนะบุรี" ให้ถูกต้อง:

ใส่รูปในกระทู้ คลิก >>
Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 
                                           
Back to top