Home Webboard ArticlesKnowledges  

ตอบ

Warning: this topic has not been posted in for at least 120 days.
Unless you're sure you want to reply, please consider starting a new topic.
ชื่อ:
อีเมล์:
หัวข้อ:
ไอค่อนข้อความ:

ใส่รูปในกระทู้ คลิก >>
Verification:
ธงชาติไทยมีกี่สี ตอบเป็นเลขอารบิก:

shortcuts: กด alt+s เพื่อตั้งกระทู้ หรือ alt+p แสดงตัวอย่าง


สรุปหัวข้อ

ข้อความโดย: เซียวเหล่งนึ่งฯ
« เมื่อ: 14, มีนาคม 2011, 02:18:12 PM »

บางบอร์ดก็ทุกอย่างผ่านหมด  แต่ไตเติลชื่อบอร์ดเสียหาย ทั้งที่ใช้ภาษาไทยอักษณธรรมดา
555+

ที่จริงมันเล็กน้อยเนอะ  ขอแค่แมสเสจ-ทอปิค มันสมบูรณ์ก็พอใจอย่างแรงละ 
ถ้าพวกนี้เสียหายนี่หละงานเข้าของจริง :haha: 

ทิป
1. สำรองไว้ให้หมด ดาต้าเบส  ไฟล์ใน /ธีม
2. คอนเวิทพวกไฟล์เทมเพลทด้วย ไม่อย่างนั้นบางเทมเพลทที่มีการแสดงภาษาไทยจะเพี้ยน
3. กรณีบอร์ดที่โมฯมาจนเละ หรือโมจนจำไม่ได้ว่าทำอะไรมั่ง  ไม่ควรอัพไฟล์ใหม่ทับ  ต้องเอาไฟล์เดิมมาเซฟแอสยูทีเอฟ
ไม่เยอะหรอก ทั้งธีม+ภาษา ดีฟอลด์ก็ 68 ไฟล์เอง  :haha:
4. ถ้ามีการใส่ภาษาไทยลงในไฟล์อังกฤษ  ต้องไปเอนโค๊ดไฟล์นั้นให้เป็น ยูทีเอฟ
5. เมื่อแก้ไฟล์ภาษาแล้ว  ต้องลบไฟล์ภาษาเ้ดิมทิ้งด้วย  ไม่งั้นสมาชิกที่ใช้ภาษาไทย จะยังจำค่าภาษาตัวเดิม ก็เป็นต่างดาวแน่นอน
ข้อความโดย: zelda
« เมื่อ: 13, มีนาคม 2011, 10:04:57 PM »


อืม เป็นเหมือนกันครับพี่ตู่ คอนเวิร์ทจาก latin1 ---> utf8
ทุกอย่างโอเคหมด ยกเว้นชื่อบอร์ด บางบอร์ด เท่านั้น
ลองทุกอย่างเท่าที่จะนึกออกแล้ว ก็ยังไม่ได้ ตอนนี้ก็ยังงงๆอยู่ว่าทำไมมันเป็นเฉพาะชื่อบอร์ดบางบอร์ด

ปล.ชื่อบอร์ดเป็นภาษาไทยหมด ไม่มีภาษาอังกฤษแทรก
ข้อความโดย: icman
« เมื่อ: 13, มีนาคม 2011, 09:47:32 PM »

ลอง save file เป็น utf-8 ด้วยซิครับ
ข้อความโดย: เซียวเหล่งนึ่งฯ
« เมื่อ: 13, มีนาคม 2011, 06:24:17 PM »

เรื่องของเรื่องคือช่วงนี้คอนเวิทบอร์ดจาก ทีไอเอส >>> ยูทีเอฟ ค่อนข้างบ่อย
ส่วนใหญ่ก็ไม่มีปัญหา แปลงได้ผ่านหมด
แต่วันนี้ทำบอร์ดแมว (ลิตเติลแคท) แล้วเจอปัญหาแก้ไม่ตก

- คอนเวิทแล้วกระทู้สมบูรณ์ดี
- ไฟล์ภาษายูทีเอฟ สมบูรณ์ดี
** แต่ชื่อหมวดหมู่และชื่อบอร์ดไม่สามารถแสดงผลได้ ตัวอย่างตามรูปแนบ ที่วงเอาไว้
เข้าไปดูในฐานข้อมูล ฟิลด์เป็นยูทีเอฟทั้งหมดแล้ว แต่อักขระในฟิลด์ก็เป้นสี่เหลี่ยมเหมือนกัน

อันที่จริงถ้ามองข้าม  จะแก้ก็แค่ไปแก้ไขชื่อหมวดหมู่ชื่อบอร์ดก็ได้แล้ว
แต่.. มันคาใจ ทุกอย่างสมบูรณ์ เสียแค่จุดเดียว
ท่านใดพอเดาสาเหตุได้ ช่วยไขข้อข้องใจทีจ้า


..


Sitemap 1 2 3 4 5 6 
Back to top