Home Webboard ArticlesKnowledges  
ข่าวประกาศ:

:: กติกา มารยาท ในการใช้งานเว็บบอร์ด ::
กรุณากรอกอีเมล์จริงในการสมัคร และรับอีเมล์ยืนยันเพื่อใช้งานในบอร์ด


ตอบ

Warning: this topic has not been posted in for at least 120 days.
Unless you're sure you want to reply, please consider starting a new topic.
ชื่อ:
อีเมล์:
หัวข้อ:
ไอค่อนข้อความ:

ใส่รูปในกระทู้ คลิก >>
Verification:
ธงชาติไทยมีกี่สี ตอบเป็นเลขอารบิก:

shortcuts: กด alt+s เพื่อตั้งกระทู้ หรือ alt+p แสดงตัวอย่าง


สรุปหัวข้อ

ข้อความโดย: Jiewky
« เมื่อ: 14, พฤศจิกายน 2010, 12:28:32 PM »

เป็นเหมือนกันเลยครับ แหะๆๆๆ ยังไม่หายทำไงดีครับ
ข้อความโดย: naruto-hero.co.cc
« เมื่อ: 02, สิงหาคม 2010, 01:15:37 AM »

ทำใด้แล้วคร๊าบบบบบบบบบบบบ แต่ของผมต้องปรับเป็น

$db_character_set = 'latin1'

ตามที่อยู่ในดาต้าเบสอันเก่า ขอบคุณมากๆนะครับ จุ๊บ 2 ที ฮ่าๆๆๆๆๆ
ข้อความโดย: meebear
« เมื่อ: 09, มิถุนายน 2010, 09:07:27 PM »

ขอบคุณครับ หา Phpmyadmin เจอแล้วเข้าไปดูปรากฏว่าของผมเป็น $db_character_set = 'tis620';
เลยไปปรับ code ใน settings.php  แล้วพอใส่เข้าไปในเว็บบอร์ด

ปรากฏว่าจากเดิมที่มีภาษาไทยในส่วนเนื้อหา ฟอรั่ม กลายเป็นเป็นต่างด้าวทั้งหมดเลยครับ  :shocked:
ข้อความโดย: UnclEo
« เมื่อ: 08, มิถุนายน 2010, 12:25:18 PM »

เข้าทางนี้ครับ
http://123.456.789.000/phpMyAdmin/

รายละเอียดพวกนี้คุณต้องได้มาตอนเช่าโฮสต์
ข้อความโดย: meebear
« เมื่อ: 08, มิถุนายน 2010, 12:06:01 PM »

รบกวนถามนิดนึงครับว่า แล้ว phpmyadmin นี่มันอยู่ตรงไหนครับ
(พอดีมือใหม่ครับ ไม่ได้มีความรู้ทางcode อะไรเลย)
ข้อความโดย: เซียวเหล่งนึ่งฯ
« เมื่อ: 11, กุมภาพันธ์ 2010, 12:09:29 PM »

ให้เข้าพีเอชพีมายแอดมิน 
- ดูว่าเทเบิลต่างๆเป็นเอนโค๊ดอะไรอยู่  เปลี่ยนทั้งหมดให้เป็น ยุนิโค๊ด
- เข้าไปดูทุกเทเบิล  เปลี่ยนฟิลด์ต่างๆ ให้เป็นยูนิโค๊ด
ข้อความโดย: Mikas
« เมื่อ: 10, กุมภาพันธ์ 2010, 10:26:18 PM »

นั้นสิครับ 2,3  ดูที่ไหน

ตอนนี้ เจอปัญหานี้อยู่เหมืออนกัน
ข้อความโดย: เรย์
« เมื่อ: 04, พฤษภาคม 2009, 09:49:16 PM »

โดยปกติแล้ว $db_character_set = มันก็มีอยู่แล้ว ถ้าเรา chmod setting & setting_back เป็น 777 หมายถึงไฟล์ setting & setting_back สามารถเขียนทับได้

แต่ถ้าเปิดดูในไฟล์ที่ยังไม่ผ่านการ install มันก็ไม่มี เพราะยังไม่ได้เขียนบันทึกไว้ ที่ยังเป็นปัญหา ภาษาไทยเป็นอักษรต่างดาวอยู่ ให้ดูที่

1. localhost

    * Server version: x.x.xx-standard-log
    * Protocol version: 10
    * Server: Localhost via UNIX socket
    * User: xxxxx_xxxxx[แอท]localhost
    * MySQL charset: UTF-8 Unicode (utf8)

2.  localhost - db_prefix_db_name
   
    * db_table
    * Collation = utf8_general_ci
   
3.  localhost - db_prefix_db_name-db_table
   
    * Operations
    * Collation = utf8_general_ci

ทั้ง 3 ส่วนนี้ต้องเป็น UTF-8
   
     

ข้อ 2, และ ข้อ 3, ดูได้จากที่ไหนครับ
ข้อความโดย: noname
« เมื่อ: 25, กรกฎาคม 2008, 06:43:16 PM »

โดยปกติแล้ว $db_character_set = มันก็มีอยู่แล้ว ถ้าเรา chmod setting & setting_back เป็น 777 หมายถึงไฟล์ setting & setting_back สามารถเขียนทับได้

แต่ถ้าเปิดดูในไฟล์ที่ยังไม่ผ่านการ install มันก็ไม่มี เพราะยังไม่ได้เขียนบันทึกไว้ ที่ยังเป็นปัญหา ภาษาไทยเป็นอักษรต่างดาวอยู่ ให้ดูที่

1. localhost

    * Server version: x.x.xx-standard-log
    * Protocol version: 10
    * Server: Localhost via UNIX socket
    * User: xxxxx_xxxxx[แอท]localhost
    * MySQL charset: UTF-8 Unicode (utf8)

2.  localhost - db_prefix_db_name
   
    * db_table
    * Collation = utf8_general_ci
   
3.  localhost - db_prefix_db_name-db_table
   
    * Operations
    * Collation = utf8_general_ci

ทั้ง 3 ส่วนนี้ต้องเป็น UTF-8
   
     
ข้อความโดย: mc
« เมื่อ: 25, กรกฎาคม 2008, 06:07:48 PM »

ตอนติดตั้ง ให้ติดตั้งเป็นภาษาไทยนะครับ แล้วไปดูใน phpmyadmin ว่า เป็น ภาไทยแบบ tis620 หรือ utf-8...หลังจากนั้น ค่อยดึงไฟล์ settings.php มาแก้ไข โดยเพิ่มโค้ดดังกล่าวเข้าไป
แล้วลองโพสต์ใหม่ดูนะครับ
ข้อความโดย: touch977
« เมื่อ: 25, กรกฎาคม 2008, 12:25:09 AM »

ขออภัยนะครับ  ผมเข้าไปแก้ตามที่แนะนำทุกอย่างแล้วยังไม่เป็นภาษาไทยเลย  ต้องทำอย่างไรต่อครับ...เด็กใหม่ในวงการ smf
touch977[แอท]hotmial.com
ข้อความโดย: aodify
« เมื่อ: 24, กรกฎาคม 2008, 11:17:56 AM »

ของผมมีอยู่แล้วครับ  นึกว่าจะได้ตามแก้อีก

ขอบคุณครับ
ข้อความโดย: เซียวเหล่งนึ่งฯ
« เมื่อ: 24, กรกฎาคม 2008, 11:13:12 AM »

ขอบคุณจ้า
ข้อความโดย: mc
« เมื่อ: 24, กรกฎาคม 2008, 08:39:32 AM »

สวัสดครับผม......วันมีทริปเล้กๆน้อยๆมาฝากนะครับพี่น้อง.... เมื่อท่านติดตั้ง smf บอร์ดแล้ว ลองโพสดูนะครับ..เมื่อเสร็จแล้วให้ไปตรวจสอบภาษาไทย(ที่โพสไว้)ในฐานข้อมูล(phpmyadmin) ด้วยนะครับ เพราะบางทีแสดงในบอร์ดมันจะเป็นภาษาไทย(ไม่มีปัญหาอะไร) แต่ในฐานข้อมูลกลับ เป็นภาษาต่างด้าว จะมีปัญหาตอนที่ท่านย้ายเชิฟเวอร์ใหม่ละครับ ก็เลยนำโค้ด มาฝาก (ถ้าหากเป็นกรณีอย่างผมว่านะครับ)

-เมื่อติดตั้ง บอร์ด smf เสร็จแล้ว เป็นไทย tis620 หรือ utf-8
ให้แทรกโค้ดนี้
$db_character_set = 'tis620'; (กรณีใช้ tis620) หรือ
$db_character_set = 'utf-8'; (กรณีใช้ utf-8) ในไฟล์ settings.php ในบรรทัดสุดท้าย ก่อน ?>


ในฐานข้อมูล phpmyadmin ก็จะเป็นภาษาไทยครับ :crying:
Sitemap 1 2 3 4 5 6 7 8 9 10 
Back to top